Напишите программу,которая считает сумму цифр введенного числа(паскаль)

0 голосов
131 просмотров

Напишите программу,которая считает сумму цифр введенного числа(паскаль)


Информатика (19 баллов) | 131 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,sum:integer;
begin
writeln('Vvedite chuslo');
readln(n);
repeat
sum:=sum+(n mod 10);
n:=n div 10;
until n=0;
writeln('summa=',sum);
end.

(2.2k баллов)