Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и...

0 голосов
55 просмотров

Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и меняет местами значения первого и последнего элементов массива.На экран выводятся исходные и преобразованные значения.Надо очень СРОЧНО!!!!!!!!!!!!!!!!!!!!!!


Информатика (110 баллов) | 55 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

program xxx;

    var i : integer;

         a : array[1..15] of real; 
         n : real; 
begin 
  randomize; 
  for i:=1 to 15 do 
    a[i]:=random(20)-20; 

   writeln('исходный массив А:');

   for i:=1 to 15 do

      write(a[i]);

   n:=a[1];

   a[1]:=a[15];

   a[15]:=n;

   writeln('полученный массив А:');

   for i:=1 to 15 do

      write(a[i]);

   readln

end.

  

(52.1k баллов)
0 голосов

var m:array[1..15] of real; 
i:integer; 
n:real; 
begin 
randomize; 
for i:=1 to 15 do 
begin 
m:=random(20)-20; 
if( m<0) then <br>begin 
m:=sqr(m); 
end;