Написать программу в Паскале. Даны два числа.Меньшее из них замените полусуммой этих...

0 голосов
124 просмотров

Написать программу в Паскале. Даны два числа.Меньшее из них замените полусуммой этих чисел, а большее - их произведением. Составить блок-схему.


Информатика (87 баллов) | 124 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b:integer;
begin 
writeln('a=');
readln(a);
writeln('b=');
readln(b);
if (a>b) then  begin 
b:=(a+b)/2;
a:=a*b;
 end
else 
begin 
a:=(a+b)/2;
b:=a*b;
end;
writeln('a=',a, ' b=', b);
readln;
end.