ПОМОГИТЕ ПОЖАЛУЙСТА!! нужно написать программу в Паскале! только там функция такая...

0 голосов
34 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА!!
нужно написать программу в Паскале!
только там функция такая y=ax^2+bx+c


image

Информатика | 34 просмотров
0

сейчас

0

значения целые или вещественные?

0

ага

Дан 1 ответ
0 голосов
Правильный ответ

Var
min,max,a,b,x,y,p,q,i:integer;
begin
   writeln('Введите  p, q');
   readln(p,q);
       writeln('Введите a,b');
       readln(a,b);  
min:=32000;max:=-32000;         
     for i:=p+1 to q do             
            begin                   
               y:=a*sqr(i)+b*i +i;                 
               writeln('y: ',y);                                 
                      if y                          min:=y;                                 
                      if y>max then                                     
                           max:=y;             
             end;         
writeln;writeln('min ',min,'  max: ',max);
end.

(9.6k баллов)
0

Это диапазон целого типа. Для поиска минимального выбираем самое большое значение, которое может быть. Вообще я просто приближенно написала 32000, вообще это от -32768 до 32767. Но вряд ли Вы будете выбирать такие значения. Если при поиске минимально не присвоить самое большое значение из диапазона, то "по умолчанию" в Паскаль это ноль. И тогда, если минимальное при расчете функции, окажется чуть больше 0, то в отвте будет 0. Т.к именно это значение окажется минимальным, хотя и не верным.

0

Зато любое значение, которое будет найдено у функции гарантировано окажется меньше максимально из диапазона -32000 до 32000

0

А зачем тогда диапазон дан

0

Отрезок от p до q. Это тогда зачем.

0

Я искала минимальное и максимальное на отрезке [p,q]

0

Для заданной функции

0

ну давайте