В классе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую...

0 голосов
598 просмотров

В классе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек,троек,четверок и пятерок, полученных за диктант.


Информатика (12 баллов) | 598 просмотров
Дан 1 ответ
0 голосов

Сначала вводишь кол-во учеников : 20, затем оценки (20 оценок вводишь).

var i,n,a,d,t,chet,p:integer; 
begin 
read(n); 
while iread(a);   
if a=2 then d:=d+1;   
if a=3 then t:=t+1;   
if a=4 then chet:=chet+1;   
if a=5 then p:=p+1;   
i:=i+1;   
end; 
writeln('Двоек: ',d);   
writeln('Троек: ',t);   
writeln('Четверок: ', chet);   
writeln('Пятерок: ',p);   
end.

(2.4k баллов)