Напишите программу, каторая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит...

0 голосов
326 просмотров

Напишите программу, каторая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифмитическое


Информатика (12 баллов) | 326 просмотров
Дан 1 ответ
0 голосов

// напишите программу, каторая генерирует 
//10 случайных чисел в диапазоне от 1 до 20, 
//выводит эти числа на экран и вычисляет их среднее арифмитическое

var a,b:integer;
         i:word;
beginb:=0;
randomize;
for i:=1 to 10 do
  begin
    a:=random(21);
    writeln(a);
    b:=b+a;
  end;
writeln ('Среднее арифмитическое данных чисел ',b/10);
end.

(31.5k баллов)
0

спасибо очень помог

0

Всегда пожалуйста

0

:))