Нужно написать программу, что бы буквы заменялись ** ** "заглавные", а не те, что стоят...

0 голосов
65 просмотров

Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC

Program eX_1;
var s: String;
n, i, b, j: longint;
c: char;
begin
writeln('Введи текст из сообщения выше:');
readln(s);
for i:=length(s) downto 1 do
if s[i] in ['a'..'z'] then s[i]:=Upcase(s[i])
else if s[i] in ['A'..'Z'] then s[i]:=chr(ord(s[i])+32)
else if s[i] in ['0'..'9'] then delete(s,i,1);
write(s);
end.


Информатика (94 баллов) | 65 просмотров
0

Вы сами-то посмотрели, что написали?

0

"буквы заменялись на на "заглавные", а не те, что стоят перед ними " - это как понимать?

0

буквы заменялись НЕ на "заглавные", а не те, что стоят перед ними опечатка, думаю

0

Надо чтобы не мы думали, а автор вопроса написал ясно, что ему надо.

Дан 1 ответ
0 голосов
Правильный ответ

Program eX_1;
var s: String;n, i, b, j: longint;c: char;
begin
writeln('Введи текст из сообщения выше:');
readln(s);for i:=length(s) downto 1 do
if s[i] in ['b'..'z'] then s[i]:=chr(ord(s[i])-1)
else if s[i]='a'then s[i]:='z' ;
write(s);
end.

(44 баллов)