Напишите программу, которая принимает с клавиатуры целое число и проверяет, ** какое...

0 голосов
97 просмотров

Напишите программу, которая принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно делится.
Результат проверки класс должен вывести на экран вместе с соответствующим текстовым сообщением.


Информатика (82 баллов) | 97 просмотров
0

класс?

0

и на каком языке программирования тебе надо?

0

на английском

0

капец! Ты не видишь слово "программирования"?

0

и зачем тебе программа если класс должен сам выводить ответ?

0

нам так учитель дает нам нужно написать к этой задачке программу

0

На каком языке программирования? Pascal? Basic?

0

на паскаль

0

все спасибо тебе большое)

Дан 1 ответ
0 голосов
Правильный ответ

На паскаль
var i,j,k:longint;
begin
read(i);
if i < 10 then write('Число меньше 10. Поэтому оно не имеет двузначный делитель');
for j:=10 to 99 do
if i mod j=0 then inc(k);
if k=0 then write('Ваше число не имеет двузначный делитель') else write('Ваше число имеет ',k,' делителей');
end.

(297 баллов)