Напишите программу, которая принимает с клавиатуры целое число х, а затем – серию из 29...

0 голосов
73 просмотров

Напишите программу, которая принимает с клавиатуры целое число х, а затем – серию из 29 дополнительных целых чисел (вводимых с клавиатуры).
программа должна определить, сколько чисел в серии были равны значению переменной х, а сколько – были меньше значения переменной х.


Информатика (82 баллов) | 73 просмотров
Дан 1 ответ
0 голосов

Program z2;
var x,i,n,r,m:integer;
begin
writeln('Введите x');
readln(x);
i:=1;
r:=0;
m:=0;
while(i<=29) do<br>begin
readln(n);
if(n=x) then
r:=r+1;
if(nm:=m+1;
i:=i+1;
end;
writeln('Чисел, равных х ',r);
writeln('Чисел, меньше х ',m);
end.

(3.7k баллов)
0

спасибочки)