Напишите программу которая выводит ** экран (Паскаль) а)положительные числа...

0 голосов
57 просмотров

Напишите программу которая выводит на экран (Паскаль)
а)положительные числа
б)отрицательные
в)четные
г)нечетные

На заметку(числа произвольные или любые (integer))
Исправлено:Даёться массив из N чисел вывести на экран количесвто чётных и нечётных,количество положительных и отрицательных элементов массивов


Информатика (1.8k баллов) | 57 просмотров
0

Сформулируйте задачу четче. Откуда числа берутся и т.д.

0

integer

0

integer - это всего лишь означает, что число будет целое) А сами числа откуда? Их вводит пользователь? Или просто random'ные берутся?

0

Если пользователь вводит число, получается, что для случая а) если число положительное, оно просто будет повторено и программа завершится, а если нет - то завершится молча?

0

числа вводят свои

0

Вы снова ничего не написали по существу заданных Вам вопросов

0

прошу прощения за то что в начале не правильно задачу написал и сформулировал )

Дано ответов: 2
0 голосов
Правильный ответ

Const
  nn = 100; { максимальное количество элементов }
var
  a:array[1..nn] of integer;
  i,n,k,kn,kp,ko,ke: integer;
begin
  Writeln('Введите количество элементов в массиве (n<=100): ');<br>  Readln(n);
  Writeln('Введите элементы массива');
  kn:=0; kp:=0; ko:=0; ke:=0;
  for i := 1 to n do
  begin
    Read(k); a[i]:=k;
    if k>0 then Inc(kp)
    else if k<0 then Inc(kn);<br>    if (k mod 2)=0 then Inc(ke) else Inc(ko)
  end;
  Writeln('Положительных элементов ',kp,', отрицательных ',kn);
  Writeln('четных элементов ',ke,', нечетных ',ko);
end.

Тестовое решение:
Введите количество элементов в массиве (n<=100): <br>13
Введите элементы массива
16 -5 8 21 0 -5 13 32 7 11 -4 2 -5
Положительных элементов 8, отрицательных 4
четных элементов 6, нечетных 7

(142k баллов)
0

Можно также просто вычеркнуть все, что касается массива, потому что по факту он тут не нужен.

0 голосов

Числа вводятся пользователем. Прикрепил скрин работы программы, вот сама программа:

var a:array[1..999]of integer;
i,n:integer;
begin
write ('Введите кол-во чисел: ');
readln (n);
for i:=1 to n do
begin
write ('Введите ',i,' число: ');
readln (a[i]);
end;
WRITELN;
write ('Числа введённые пользователем: ');
for i:=1 to n do
write (a[i],' ');
WRITELN;
WRITELN;
write ('Положительные: ');
for i:=1 to n do
begin
if a[i]>0 then write (a[i],' ');
end;
WRITELN;
write ('Отрицательные: ');
for i:=1 to n do
begin
if a[i]<0 then write (a[i],' ');<br>end;
WRITELN;
write ('Чётные: ');
for i:=1 to n do
begin
if a[i] mod 2 = 0 then write (a[i],' ');
end;
WRITELN;
write ('Нечётные: ');
for i:=1 to n do
begin
if a[i] mod 2 <> 0 then write (a[i],' ');
end;
end.


image
(10.7k баллов)