Помогите написать программу в с++. Используя оператор if нужно написать программу , где...

0 голосов
31 просмотров

Помогите написать программу в с++.
Используя оператор if нужно написать программу , где пользователь вводит число , а программа отображает одно из трех сообщений : число является четным , положительным . или число является нечетным , положительным. или отрицательным


Информатика (47 баллов) | 31 просмотров
0

а на 0 что выдавать?

Дан 1 ответ
0 голосов

#include
#include

int N;

int main()
{
    std::cin >> N;
    if (N % 2 == 0 && N > 0)

        std::cout << "number is even and greater than 0" << std::endl;<br>
    else if (N % 2 == 1 && N > 0)
        std::cout << "number is odd and greater than 0" << std::endl;</span>
    else if (N < 0)

        std::cout << "number is negative" << std::endl;</span>
    getch();

    return 0;
}

(1.4k баллов)