50 Баллов. Пожалуйста. В Паскаль. Написать программу, которая вводит массив из N целых...

0 голосов
44 просмотров

50 Баллов. Пожалуйста. В Паскаль. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.


Информатика (31 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;d:
array [1..10] of integer;
begin
randomize;
writeln('введите число ');
readln(b);
for a:=1 to b do begin
d[a]:=random(-20,20);
writeln('элемент массива ==> ',d[a]);
c:=c+d[a];
end;
writeln('сумма всех элементов массива ', c );
end.

(8.6k баллов)
0

Конструкция random(-20,20); допустима в Pascal ABC.

0

только в pascal ABC net.

0

Я к тому, что неплохо об этом где-то в ответе писать, если явно не указано, что решение требуется в PascalABC