Написать программу для определения веса человека. Запросить рост в см, возраст и его вес....

0 голосов
28 просмотров

Написать программу для определения веса человека. Запросить рост в см, возраст и его вес. рассчитать норму веса по формуле:
Если возраст меньше 25, то использовать формулу НОРМА ВЕСА = РОСТ -110, иначе НОРМА ВЕСА= РОСТ -100
Вывести сообщение:
Если НОРМА ВЕСА=ВЕСУ, то "ваш вес в норме"
Если НОРМА ВЕСА<ВЕСА, то "вам надо сбросить n килограмм"<br> Если НОРМА ВЕСА>ВЕСА, то "вам надо поправиться на n килограмм"


Информатика (1.9k баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var r,v,w,n,kg:real;
begin
write ('Введите рост: ');
readln (r);
write ('Введите возраст: ');
readln (v);
write ('Введите вес: ');
readln (w);
WRITELN;
if v<25 then n:=r-110 else n:=r-100;<br>if n=w then writeln ('Ваш вес в норме');
kg:=w-n;
if nkg:=n-w;
if n>w then writeln ('вам надо поправится на ',kg,' килограмм');
end.


image
image
(10.7k баллов)