Пожалуйста помогите с информатикой))) нужно написать программу для паскаля возведения...

0 голосов
48 просмотров

Пожалуйста помогите с информатикой)))
нужно написать программу для паскаля возведения числа а в степень n/


Информатика (80 баллов) | 48 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program zadacha;
var a,b,c : integer;
begin
c:=1;
write('Введите число ==> ');
readln(a);
write('Введите его степень ==> ');
readln(b);
while b<>0 do begin
c:=a*c;
b:=b-1;
end;
write('степень числа ==> ',c);
end.

(8.6k баллов)
0 голосов
program stepen;
uses crt;
var a,n,i,p : integer;
begin
write('Введите число a=');
readln(a);
write('Введите степень числа n=');
readln(n);
p:=1;
for i:=1 to n do
p:=p*a;
write('Число а в степени n = ',p)
end.
(57 баллов)