Напишите программу, которая вводит два целых числа и находит их произведение, не ис...

0 голосов
25 просмотров

Напишите программу, которая вводит два целых числа и находит их произведение, не ис пользуя операцию умножения. Учтите, что числа могут быть отрицательными. ( Паскаль)


Информатика (140 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Var a, b, i, p: integer;
begin
  writeln('Введите два целых числа');
  readln(a, b);
  p := 0;
  for i := 1 to abs(b) do
  p := p + abs(a); 
  writeln('Произведение = ', p);
end.

(330 баллов)