Задача: Дан массив из 10 целых чисел,от -20 до 20 . Напишите программу,заменяющую первый...

0 голосов
47 просмотров

Задача:
Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.

Помогите пожалуйста решить!


Информатика (15 баллов) | 47 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
var a:array [1..10] of integer;
     i,n,b:integer;
Begin
  for i:=1 to 10 do
    read(a[i]);
  for i:=1 to 10 do
  begin
    if b=0 then if a[i]<0 then <br>       begin
         a[i]:=0;
         b:=1;
       end;
  end;

  for i:=1 to 10 do
  write(a[i],' ');
End.