Нужно написать программу ** языке pascal.** вход подается 2 слова.и программа должна...

0 голосов
30 просмотров

Нужно написать программу на языке pascal.на вход подается 2 слова.и программа должна вывести буквы которые встречаются только в одном слове,но не в обоих
например: есть слова процессор и информация.
результат:п е ф м а я с н


Информатика (62 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.Net
var
  sc1,sc2:set of char;
  s1,s2:string;
  c:char;
  i:integer;
begin
  Write('Введите первое слово: '); Readln(s1);
  Write('Введите второе слово: '); Readln(s2);
  sc1:=[]; sc2:=[];
  for i:=1 to Length(s1) do Include(sc1,s1[i]);
  for i:=1 to Length(s2) do Include(sc2,s2[i]);
  foreach c in sc1+sc2-(sc1*sc2) do Write(c,' ')
end.

Тестовое решение:
Введите первое слово: процессор
Введите второе слово: информация
п я н м ф а е с и

(142k баллов)
0

что значит "sc1:=[]; sc2:=[];" и "Include"

0

Стандартные операции языка Паскаль для работы со множествами. Первая - присвоение множеству пустого значение (очистка). Вторая - добавление элемента ко множеству.

0

спасибо

0

Во избежание дальнейших вопросов: sc1+sc2 объединяет множества, sc1*sc2 дает их пересечение, а разность объединения и пересечения порождает несовпадающие элементы