Написать программу. Паскаль

0 голосов
33 просмотров

Написать программу.
Паскаль


image

Информатика (57 баллов) | 33 просмотров
0

Что означает запись b=3 и т.д. под знаком суммы? В математике она не применяется.

Дан 1 ответ
0 голосов
Правильный ответ

Первый знак - это большая греческая (чуть не написал свадьба :)) буква Сигма, что значит Сумма элементов по переменной b от 3 до N с шагом ∆b.
Она применяется, если d <= 0<br>Второй знак -это большая греческая буква Пи, что значит Произведение 
элементов по переменной с от 2 до 9.
Она применяется, если d > 0 
var a, b, c, d, db, N, L: real
writeln('Vvedite  a, d, db, N : ');
readln ( a, d, db, N );
if (d <= 0) then <br>begin
L := 0; b := 3;
while b <= N do <br>begin
L := L + b - a*d;
b := b + db;
end;
end;
else
begin
L := 1;
for c := 2 to 9 do L := L*(pow(c, a) + tan(d));
end;
writeln (L);
end.

(320k баллов)
0

Смотрим систему математических обозначений. "Большая греческая буква Сигма обозначает сумму для ЦЕЛОЧИСЛЕННЫХ значений переменной от нижнего до верхнего предела" с единичным шагом. Ибо как это интерпретация чисел натурального ряда, иногда расширяемая значением ноль. Никаких "шагов ∆b" там нет и в помине.

0

Ну вот так училка решила расширить понятие и сделать, например, с шагом 2.

0

А почему не с шагом 0.117893? А главное, почему этих "сферических коней в вакууме" должны на свой страх и риск расшифровывать отвечающие, а не авторы вопросов?

0

По сути ведь это Ваша догадка и ничто не мешает автору вопроса вдруг заявить, что она неверна. Я думаю, отвечая на подобные вопросы, мы создаем прецеденты, ведущие к наплевательству в отношении качества оформления заданий.

0

А почему не с шагом 0.117893? Да с любым шагом, он задается на входе, у меня это переменная db.

0

Да, это не более, чем моя догадка, но она весьма правдоподобна.

0

А наплевательство к оформлению заданий - это беда училки, которая так по-идиотски пишет вопросы, а не ученика.

0

Вот тут Я с Вами не соглашусь в корне. Этот ресурс предназначен не для ублажения ленивых школьников, которые даже вдуматься не желают в задание, а постят его напрямую сюда. Правила требуют, чтобы задание было надлежащим образом оформлено, т.е. не допускало двояких смыслов и не было расплывчатым. Нам тут нет дела до "учебников и училок", у нас автор задания тот, кто его публикует и он ОБЯЗАН привести его в надлежащий вид в соответствии с Правилами.

0

А для этого автор должен четко понимать задание, а также форму и способ получения решения. И четко излагать понятое в задании, а не ограничиваться фразой "Напишите мне про pop и push в паскале", - сегодня как раз такое "задание" было.

0

Посмотрите. какие вопросы висят: "Алгоритм управления чертежником число 82 вектор и точка вот так" - это что? Или: "Составьте алгоритм своего сотового телефона для чертежника". Или: "Концелярская кнопка какой имеет состав,действие и важность". Давайте на них ответим?