Написать программу ** Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км....

0 голосов
276 просмотров

Написать программу на Паскале.
Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего. Определите в какой день он пробежит больше 20км, и в какой день суммарный пробег за все дни превысит 100км


Информатика (17 баллов) | 276 просмотров
Дан 1 ответ
0 голосов

Program abc;
var a,b,i: real;
begin
a:=10; // 10 км за день
b:=1; // счетчик дней
Repeat
a:=a+a*0.1; // +10% от пробега предыдущего
b:=b+1;  // счетчик дней
Until a>20;  //суммарный пробег за все дни превысит 20км
writeln ('Пробег превысил 20км. на день № ',b);
Repeat
a:=a+a*0.1;  // +10% от пробега предыдущего
b:=b+1; // счетчик дней
Until a>100; //суммарный пробег за все дни превысит 100км
writeln ('Пробег превысил 100км. на день № ',b);
end.

(724 баллов)