Информатики!!! Помогите, срочно надо!! ВОТ ЗАДАЧА: Пользователь вводит с клавиатуры 3...

0 голосов
22 просмотров

Информатики!!! Помогите, срочно надо!! ВОТ ЗАДАЧА:
Пользователь вводит с клавиатуры 3 числа a, b, c , являющиеся сторонами треугольника. Написать программу использующую подпрограмму функцию для вычисления площади треугольника по формуле Герона. (В паскале) Напишите пожалуйста программу

Формула Герона: S=p*(p-a)(p-b)(p-c) (все под корнем). p=a+b+c/2


Информатика (249 баллов) | 22 просмотров
0

Пожалуйста, ну кто-нибудь

Дан 1 ответ
0 голосов
Правильный ответ

Var
p,x,y,z:real;
function s(a,b,c:real):real;
    begin       
          p:=(a+b+c)/2;       
           S:=sqrt(p*(p-a)*(p-b)*(p-c))
     end;
begin
     readln(x,y,z);
     s(x,y,z);
     writeln(s(x,y,z));
end.

(9.6k баллов)