Даны целые числа а и в (а<в) написать программу вычисления всех целых чисел от а до в...

0 голосов
42 просмотров

Даны целые числа а и в (а<в) написать программу вычисления всех целых чисел от а до в включительно


Информатика (15 баллов) | 42 просмотров
0

вывести все числа в промежутке от а до б включая их самих?

0

да

Дано ответов: 2
0 голосов
Правильный ответ

Var
    a, b, i: integer;

begin
    writeln('введите число a');
    readln(a);
    writeln('введите число b');
    readln(b);
   
    if (a > b) then begin
        i := b;
        b := a;
        a := i;
    end;
   
    for i := a to b do
        writeln('число в промежутке ==>', i);
   
end.

(53.1k баллов)
0 голосов

Var a,b,c:integer;
begin
writeln('введите число a');
readln(a);
writeln('введите число b');
readln(b);
for a:=a to b do begin
writeln('число в промежутке ==>',a);
end;
if a>b then
 for b:=b to a do begin
writeln('число в промежутке ==>',b);
end;
end.

(8.6k баллов)
0

я добавил проверку, на всякий случай. Надеюсь вы не против

0

нет спасибо большое

0

вы не могли бы отметить мой ответ как лучший?

0

буду признателен

0

а не легче просто поменять а и в местами ?

0

а какая разница?

0

избежание одной из важных ошибок програмирования - копипаст

0

а если бы цикл был не в одну строчку а в 10 строк, ты тоже бы его только скопировал и поменял буквы местами?