Напишите программу в паскале. Грузовой автомобиль выехал из одного города в другой со...

0 голосов
211 просмотров

Напишите программу в паскале.
Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч
Через t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. составить программу,определяющею,догонит легковой автомобиль грузовой через t1 х после своего выезда


Информатика (17 баллов) | 211 просмотров
0

насколько я понял то скорости и время нужно ввести самому?

Дан 1 ответ
0 голосов

 const     
v1 = 5; //Скорость грузовика     
v2 = 10;//Скорость легкового автомобиля     
t = 5;  //Задержка между выездом      

var   
t1 : integer; //Время, от выезда легкового авто  

begin 
readln (t1);   
if v1 * (t +t1) <= v2 * t1 then    <br>writeln ('Догонит')   
else    writeln ('Не догонит'); 
end.   

{ Уравнение зависимости координаты от времени 
x = xo + vt 
x0 = 0  

xg(t) = v1*(t+t1) 
xl(t) = v2*t1  

xl(t) >= xg(t) }

(2.6k баллов)