Напишите программу для решения следующей задачи. ** контрольной работе по алгебре...

0 голосов
528 просмотров

Напишите программу для решения следующей задачи.

На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.
(Pascal)


Информатика (20 баллов) | 528 просмотров
0

правильность решения вводиться вами?

0

и на каком языке писать программу

0

так понятнее, спасибо.

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c,d,e:integer;
begin
d:=1;
e:=0;
writeln('введите количество учеников');
readln(a);
for b:=1 to a do begin
writeln('введите количество правильных ответов для ',d,' ученика' );
readln(c);
while (c>10) or (c<0) do begin<br>writeln('вы ввели неверное число, попробуйте снова');
readln(c);
end;
if c = 10 then e:=e+1;
d:=d+1;
end;
if (e>=1) then writeln('yes ')
else writeln('no');
end. 

(8.6k баллов)
0

я тут добавил контроль за правильностью введения числа правильных ответов, надеюсь вы не против.

0

Спасибо большое

0

вы не отметите мой ответ как лучший?

0

буду признателен

0

Я бы с радостью,но не знаю как

0

ну, ничего страшного.

0

так или иначе, я вам помог

0

и я вам признательна за это