Написать программу вычисления значения выражения: sin2*sin4*sin6*…*sin2N при заданном N...

0 голосов
128 просмотров

Написать программу вычисления значения выражения:
sin2*sin4*sin6*…*sin2N при заданном N (цикл «до»)


Информатика (28 баллов) | 128 просмотров
0

язык какой?

0

паскаль

0

через Repeat Until?

0

да

0

сейчас

0

Спасибо)

Дан 1 ответ
0 голосов

Var
n:integer;
x,p:real;
begin
    x:=2;p:=1;
writeln('N?');
readln(n);
       repeat
           p:=p*Sin(x);
           x:=x+2;
       until x>n*2;
writeln('p: ',p:4:2);
end.


(9.6k баллов)