Написать программу , которая увеличивает число ** 7, если оно меньше нуля и уменьшает **...

0 голосов
62 просмотров

Написать программу , которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. Если исходное число больше 0


Информатика (182 баллов) | 62 просмотров
0

Паскаль?

Дано ответов: 2
0 голосов
Правильный ответ
var x : real;
begin 
 writeln ( 'Введите число : '); 
 readln (x); 
  if (x<0) then x:=x+7  <br>  else if (x>0) then x:=x-2; 
 writeln (' Конечное число : ',x);
end.
(1.3k баллов)
0

Спасибо)

0 голосов

Var a,b,c:integer;
begin
writeln('введите число');
readln(a);
if a<0 then b:=a+7 else b:=a-2;<br>if a=0 then while a=0 do begin writeln('введите другое число'); end;
writeln('полученное число ', b);
end.

(8.6k баллов)
0

Спасибо)