Срочно!!! Напишите программу, которая вводит натуральные числа A и N и вычисляет A^N. ( С использованием цикла (если это вообще применимо)).
Function Power(x,y:real):real; begin if x=0 then Power:=0 else if x>0 then Power:=exp(ln(x)*y) else Power:=-exp(ln(abs(x))*y); end; var x,y:real; begin readln(x,y); writeln(power(x,y)); end.