Напишите программу которая вводит координаты двух точек ** числовой оси и выводит...

0 голосов
112 просмотров

Напишите программу которая вводит координаты двух точек на числовой оси и выводит расстояние между ними. Учитывайте , что первой может быть введена меньшая координата.


Информатика (19 баллов) | 112 просмотров
Дан 1 ответ
0 голосов

Var x1,y1,x2,y2,r:real; 
begin 
writeln('Введите x,y первой точки'); 
read(x1,y1); 
writeln('Введите x,y второй точки'); 
read(x2,y2); 
r:=sqrt(sqr(x2-x1)+sqr(y2-y1)); 
writeln('Длина отрезка:', r:1:1); 
end.

(2.4k баллов)