Написать программу ** паскале где надо найти сумму чисел из отрезка от а до б, кратным 7...

0 голосов
30 просмотров

Написать программу на паскале где надо найти сумму чисел из отрезка от а до б, кратным 7 и вывести числа на печать в строчку

цикл с шагом -1
то есть down to


Информатика (15 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var

var
a,b,i:integer;
begin    
readln(a,b);
if a>b then
  begin
     for i:=a downto b do
            if i mod 7= 0 then
                  write(i:4) 
   end
else
        for i:=b downto a do
             if i mod 7= 0 then
                  write(i:4) ;
end.

    

(9.6k баллов)