Пожалуйста поскорее можно? Напишите программу,которая находит среднее из трех введенных...

0 голосов
74 просмотров

Пожалуйста поскорее можно?
Напишите программу,которая находит среднее из трех введенных числе. Предполагается что все три числа различные


Информатика (12 баллов) | 74 просмотров
0

среднее арифм?

0

не знаю, написано все с учебника

Дан 1 ответ
0 голосов

Я думаю, что имеется в виду среднее по значению
Pascal : 
var arr : array[0..2] of integer; { если числа целые }
     i, j, t : integer;
begin
  read(arr[0], arr[1], arr[2]); 
  // самый простой способ - это отсортировать массив
  // в данном случае можно использовать сортировку "пузырьком"
  for i := 0 to 2 do 
    for j := 0 to 2 do 
      if arr[ j ] > arr[ j + 1]
        begin
          t := arr[ j ];
          arr[ j ] := arr[ j + 1];
          arr[ j + 1 ] := t;
        end;

 //Конечно, среднее по значению число будет храниться в элементе arr[1]
  writeln(arr[1]);
end.
На случай, если в учебнике просят среднее арифметическое, понятно, что нужно просто вывести ( arr[0] + arr[1] + arr[2] ) / 3
Если есть какие-то вопросы, то можете написать личное сообщение

(173 баллов)