Помогите написать программу ** паскале Даны 2 массива. Элемент одного массива умножить **...

0 голосов
57 просмотров

Помогите написать программу на паскале
Даны 2 массива. Элемент одного массива умножить на элемент другого в обратном порядке. Заранее спасибо


Информатика (81 баллов) | 57 просмотров
0

да

0

Паскаль?

0

Т.е. я хотел спросить версию Паскаля

0

ага) еще можно так: а[1,1] * б[n,n] ; a[1,2] * b[n, n-1]

0

ну желательно free

0

или ABC

0

Может еще пятимерный массив взять? Зачем усложнять программу двумерностью?

0

ну ок, давай твой вариант)

0

Alviko, ты тут?

0

нет, я не тут)))

Дан 1 ответ
0 голосов
Правильный ответ

Const
  n = 8;

var
  a,b: array[1..n] of integer;
  i, k, s: integer;

begin
  Randomize;
  Write('Массив 1:  ');
  for i := 1 to n do
  begin
    a[i] := Random(50)+1;
    Write(a[i]:5);
  end;
  Writeln;
  Write('Массив 2:  ');
  for i := 1 to n do
  begin
    b[i] := Random(50)+1;
    Write(b[i]:5);
  end;
  Writeln;
  Write('Результат: ');
  for i := 1 to n do Write(a[i]*b[n-i+1]:5);
  Writeln
end.

Тестовое решение:
Массив 1:     39   10   14   23   37   38   33   48
Массив 2:     22   45    1   17   16   42   21   39
Результат:  1521  210  588  368  629   38 1485 1056



(142k баллов)