Написать программу которая складывает числа от 4 до 100

0 голосов
23 просмотров

Написать программу которая складывает числа от 4 до 100


Информатика (121 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Var i,sum:integer;
Begin
for i:=4 to 100 do
  begin 
      sum:=sum+i; 
      writeln('Summa#',i,'=',sum);
  end;
end.

(242 баллов)
0

Принципиальная ошибка. Нет начального присваивания переменной sum. Стандарт языка Pascal НЕ ОПРЕДЕЛЯЕТ, какое значение имеет неинициализированная переменная.