Нужна помощь с информатикой!В файле записано не более 100 целых чисел вывести в другой...

0 голосов
44 просмотров

Нужна помощь с информатикой!В файле записано не более 100 целых чисел вывести в другой текстовый файл те же числа отсортированные в порядке возрастания


Информатика (304 баллов) | 44 просмотров
0

укажите на каком языке программирования нужно составить программу

0

паскаль

0

какая из сортировок должна использоваться или нет разницы

0

без разницы, главное чтоб работало

Дан 1 ответ
0 голосов
Правильный ответ

Var
{Файл 1.txt необходимо создать }
n,i,j,c1:integer;
a:array[1..100] of integer;
f:text;
begin
 {чтение данных с файла 1.txt}
 assign(f,'1.txt'); reset(f);
 i:=0;
 while not eof(f) do
 begin
   i:=i+1;
   read(f,a[i]);
 end;
 n:=i;
 close(f);
{Сортировка}
  for i:=1 to n-1 do
  for j:=i+1 to n do
    if a[i]>a[j] then
        begin
         c1:=a[j];
         a[j]:=a[i];
         a[i]:=c1;
        end;
 {вывод в файл 2.txt отсортированного массива}
  assign(f,'2.txt');  rewrite(f);
  for i:=1 to n do
   write(f,a[i]:5);
  close(f);

 end.


(846 баллов)
0

файл C:/Users/777/Destkop/1.txt не найден, это его создать надо? Если да, то где?)

0

а всё понял, извините, если потревожил