Язык Pascal ABC. Напишите программу: Дан двухмерный массив A[1..m,1..n]. Написать...

0 голосов
50 просмотров

Язык Pascal ABC. Напишите программу:
Дан двухмерный массив A[1..m,1..n]. Написать программу построения одномерного массива B[1..m], элементы которого соответственно равны суммам элементов строк.


Информатика (214 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Const
 m=100;
 n=100;
var
a:array[1..m,1..n]of integer;
b:array[1..m]of integer;
i,j:integer;
begin
for i:=1 to m do
for j:=1 to n do
 a[i,j]:=random(200)-100;
for i:=1 to m do
b[i]:=0;
for i:=1 to m do
for j:=1 to n do
b[i]:=b[i]+a[i,j];
for i:=1 to m do
write(b[i],' ');
end.

(514 баллов)