Язык Borland C++ никаких паскалей Написать программу,позволяющую для заданного...

0 голосов
80 просмотров

Язык Borland C++ никаких паскалей
Написать программу,позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.Длина массива N
задается пользователем как константное выражение.Исходные данные задать вручную или с помощью генератора случайных чисел,учитывая формат элементов массива А.Тип результата определяется из контекста.
-Вычислить количество отрицательных элементов массива;
-сумму модулей элементов массива,расположенных после максимального элемента


Информатика (49 баллов) | 80 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include

using namespace std;

int main(int argc, char *argv[])
{int i,k,max,j,n,s;
srand(time(NULL)); k=0; s=0;
cout<<"Введите размерность массива:"<<endl;<br>cin>>n;
int a[n];
cout<<"Данный массив:"<<endl;<br>for (i=0;i<=n;i++) {a[i]=rand()%21-10; cout<<a[i]<<" ";}<br>max=a[0]; j=0;
for (i=0;i<=n;i++) {if (a[i]<0) k=k+1; if (a[i]>max) {max=a[i]; j=i;}}
cout<<"Количество отрицательных элементов - "<<k<<endl;<br>for (i=j+1;i<=n;i++) s+=abs(a[i]);<br>cout<<"Сумма модулей элементов массива, расположенных после максимального - "<<s<<endl;<br>
    system("PAUSE");
    return EXIT_SUCCESS;
}


(367 баллов)
0

О,теперь все шикарно))Спасибо огромное)

0

Давай я тебе скину кое -что,сумеешь решить?)

0

М? Зачем?

0

Помочь доброму человеку)нет так нет,да так да)

0

Эх, добрый человек. Не уйти мне спать. Напиши в лс текст задачи, посмотрим.

0

Скорее, помочь ленивому. Одно дело - подсказать что-то неясное, а другое - становиться на конвейер решать задачи лентяю.

0

Осуждать мы все любим.Кричать кто есть кто нам тоже нравится.Откуда вам знать лентяй я или нет?все люди когда либо нуждаются в помощи,и стоило мне раз попросить сделать работу за меня,как меня назвали лентяем.В жизни уверен вы лентяй не меньше чем я в таком случае,Александр.

0

Когда человек выкладывает несколько однотипных заданий для решения, ежу ясно, что он не желает разобраться в решении одного из них и попытаться сделать на этой основе остальные. Это и есть проявление обычной лени. Лени ума.

0

А когда еще, в нарушении принятых тут Правил, этот человек не оформляет задания, как положено, а просит "реши, я тебе скину" - это только подтверждает сделанный вывод. Да, "бывают случаи", когда надо, некогда...но для этого есть Личные Сообщения.

0

А вот на чем Ваша уверенность в моей лени основана, непонятно. Разве что на желании слегка похамить...